This project is read-only.

Application not responding when adding Scintilla object

Topics: Developer Forum, User Forum
Nov 26, 2012 at 12:31 PM


I wish to use Scintilla in my C# application.

I downloaded ScintillaNet, created item in my ToolBox, and then draged and droped Scintilla object on my window form. And waited. A waited. And then waited some more... And my application stopped responding. After some time I forcibly closed the VS studio and tried again, with the same results.

Can anyone tell me what am I doing wrong?


Thank you,


Nov 27, 2012 at 1:19 AM

Please read and follow the instructions in the link above and report back if you still have problems.



Nov 27, 2012 at 7:40 AM

Hi Jacob,

I went to the download page, and clicked to download the binaries, as written in the instructions. But I did not receive any "licens term-of-use popup" that is mentioned in the instructions.

Do you think thats the reason for my problems?


Thank you,


Nov 29, 2012 at 2:08 AM

No. It wouldn't be anything related to that. :) 

CodePlex may have changed their download behavior somewhat but so long as you can download the zip file that is the important thing.

What about the remainder of the steps? Any problems following those? Did you get the path set correctly? What version of Visual Studio, .NET, Windows are you using?

For me to help I will need more information.


Nov 29, 2012 at 4:16 AM

I followed the instructions step by step. I set the path correctly.

I use VS 2010, .NET 4, Windows 7.


Thank you,


Nov 29, 2012 at 4:17 PM


I use the same setup (VS 2010, .NET 4, Window 7) that you do and I am unable to reproduce the problem you are having. I'm about out of ideas on what could be going wrong.

One last thing you can try is to debug Visual Studio. By doing that you may be able to capture an exception or error message that would explain why VS is hanging. To do that you need to open two instances of Visual Studio. In the first one open your project. In the second one, use the Attach to Process debugging command to attach to the first instance of Visual Studio (devenv.exe). With the debugger attached, go back to the first instance with your project and attempt to drop the ScintillaNET control onto your form. If any errors occur in that process you might be able to capture them in the second instance of Visual Studio.

Hope that helps.


Dec 2, 2012 at 5:00 AM

Hi Jacob,

I decided to debug in an easier way:

I downloaded the souces of Scintilla, and added an object in code. This also cause the VS not to response.

Now I could easily debug the code, and I found that it get stucked at file Scintilla.cs, line 3729

_printing = new Printing(this);

I have proplems with my printer's services, so maybe thats the reason.

Anyway, I commented out the line and now it works.

Thanks alot for your help,




Dec 3, 2012 at 5:01 AM

So glad you got it working. :)