This project is read-only.

Can not run custom highlighting for phpscript

Nov 6, 2012 at 3:52 PM


Sorry to bother the discussions but I could not make the Syntax Highlighting for phpscript mentioned on page

What I am doing is selecting phpscript on the ConfigurationManager section. Nothing happens. I am trying to add programmatically by using 

scintilla1.ConfigurationManager.Language = "phpscript"; 

It doesn't work. Am I missing anything? I am a newbie on ScintillaNET. I would appreciate if you can give me some details.

Many thanks

Nov 6, 2012 at 9:04 PM

The piece at the bottom of the page was referring to lexers, meaning that you still have to define the keywords as well in order for the lexer to be able to function correctly. (and thus, be able to give you syntax highlighting)

Nov 6, 2012 at 9:09 PM

blah38621 thank you for your reply. so there's no default setting file like notepad++ html, PHP colors and font settings right?

Nov 8, 2012 at 12:52 AM


It's bad form to start a new discussion topic because you didn't get a quick response on the one you already created. Please continue this discussion on your original thread.


Nov 8, 2012 at 1:20 PM


It's been 4-5 days since I haven't get a response back from you + once someone replies a topic other developers do not concentrate on the topic since they think someone else already helping them. By writing a new discussion, I wanted to get the attention of another person who may help. It worked.

On the other hand I agree it is not a nice thing to do. I apologize from both you and other people on the community. I hope I haven't caused to much disturbance to the people on the discussions.

Thank you for your help and once again sorry