Visual Studio 2012, release CPU target

Topics: Developer Forum
Apr 24, 2013 at 7:34 PM
Just thought I would share a problem I had recently and my solution. I don't know if it applies to current version of ScintillaNET since I have an older version. But here it is.

I had moved a project to VS 2012. It was an old project that I decided to work on again. I noticed that my Scintilla control was not highlighting syntax anymore. I was going crazy looking at designer settings, debugging, etc. I thought I had inadvertently broken it. Then I realized that I was running in Release mode and when I tried to Debug mode latest build executable directly, it actually worked. After ruling out that I hadn't changed anything, I looked at my project's build configurations. Release configuration was set to target "Any CPU" while Debug was set to target "x86". After I changed Release to "x86" Scintilla started highlighting properly once again. So something about the "Any CPU" compilation was causing Scintilla to break.

I hope this saves someone some time and hair-pulling.